Uploaded image for project: 'Embedded Software & Tools'
  1. Embedded Software & Tools
  2. EXT_EP-9906

[RTLS] AoA multiple connection: When>4 slaves are connected, the passive node sometimes fails to track some of the connections.

    XMLWordPrintable

Details

    • Bug
    • Status: Fixed
    • High
    • Resolution: Fixed
    • SimpleLink CC13x2-26x2 SDK BLE5 Stack
    • BLE_AGAMA-1652
    • Hide
      BLE Stack BLE5-2.1.1
      BLE Stack BLE5-2.1.1 RC9
      Show
      BLE Stack BLE5-2.1.1 BLE Stack BLE5-2.1.1 RC9
    • Hide
      BLE Stack BLE5-2.1.x
      BLE Stack BLE5-2.1.1 RC12
      BLE Stack BLE5-2.2.2
      BLE Stack BLE5-2.2.2 RC7
      Show
      BLE Stack BLE5-2.1.x BLE Stack BLE5-2.1.1 RC12 BLE Stack BLE5-2.2.2 BLE Stack BLE5-2.2.2 RC7
    • CC26X2R1

    Description

      Git \ Installer version: simplelink_cc13x2_26x2_sdk_3_40_00_37_eng

      Test-Bed:  RTLS

      Problem reproducibility: 100%

      Problem description: When trying to perform AOA with multiple connections the passive node seems to miss reports and even miss the AOA process for certain connection handles. 

      in addition, passive wont track reports at all. 

      steps to reproduce:

      1. flash rtls master slave and passive with relevant hexs
      2. run rtls_example.py
      3. check that the passive tracked successfully all the connections

      Attachments

        Activity

          People

            syncuser TI User
            syncuser TI User
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: