Uploaded image for project: 'Embedded Software & Tools'
  1. Embedded Software & Tools
  2. EXT_EP-10721

XDCTools Gmake 4.2.1 Build Fails with macOS 12.0 (Monterey)

    XMLWordPrintable

Details

    • Bug
    • Status: In Development
    • High
    • Resolution: Unresolved
    • XDCTools
    • XDCTOOLS-460
    • Hide
      XDCTOOLS_3_61_04
      3.51.02
      XDCTOOLS_3_62_00
      Show
      XDCTOOLS_3_61_04 3.51.02 XDCTOOLS_3_62_00
    • Hide
      A recommended workaround is to copy a version of gmake 4.3 into the XDCTools directory.

      For example the CCS gmake distribution into the XDCTools distribution and this can be done by:
      cd /ti/xdctools_3_51_03_28_core/. (Where the XDCTools being used by the project is installed)
      cp gmake gmake_xdc
      cp ../ccs1100/ccs/utils/bin/gmake . (Replace CCS gmake version in XDCTools installation)
      Show
      A recommended workaround is to copy a version of gmake 4.3 into the XDCTools directory. For example the CCS gmake distribution into the XDCTools distribution and this can be done by: cd /ti/xdctools_3_51_03_28_core/. (Where the XDCTools being used by the project is installed) cp gmake gmake_xdc cp ../ccs1100/ccs/utils/bin/gmake . (Replace CCS gmake version in XDCTools installation)

    Description

      XDCTools builds will fail with error status 139.

      This occurs as the published version of gmake in XDCTools (4.2.1) is not compatible with macOS 12.0 (Monterey) which requires 4.3.

      Attachments

        Activity

          People

            syncuser TI User
            syncuser TI User
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated: