Uploaded image for project: 'Embedded Software & Tools'
  1. Embedded Software & Tools
  2. EXT_EP-10604

[Mesh][AE][Stability] Mesh nodes with AE fail to send/receive messages after certain amount of messages are being transferred in the network

    XMLWordPrintable

Details

    • Bug
    • Status: Fixed
    • Medium
    • Resolution: Fixed
    • SimpleLink CC13x2-26x2 SDK BLE5 Stack
    • BLE_AGAMA-3634
    • BLE stack BLE5-2.2.3 RC9
    • Hide
      BLE Stack BLE5-2.2.4 RC1
      BLE Stack BLE5-2.2.4
      Show
      BLE Stack BLE5-2.2.4 RC1 BLE Stack BLE5-2.2.4
    • CC26X2R1

    Description

       

      • Git \ Installer version:
        • 5.30.00.52
      • Last successful Installer:
        • N\A
      • Test-Bed:
        • Mesh TBM Network (8 AE nodes, with different feats enables)
      • Application:
        • Mesh AE with different features (basic node/relay/proxy/mesh+SP)
          • OA_3_1|Set Hex file ble5_simple_mesh_node_ae_proxy_static_cc26x2r1_ccs_Release.hex
          • OA_3_2|Set Hex file ble5_simple_mesh_node_ae_and_peripheral_static_cc26x2r1_ccs_Release.hex
          • OA_3_3|Set Hex file ble5_simple_mesh_node_ae_relay_static_cc26x2r1_ccs_Release.hex
          • OA_3_4|Set Hex file ble5_simple_mesh_node_ae_basic_node_static_unicast4_cc26x2r1_ccs_Release.hex
          • OA_3_5|Set Hex file ble5_simple_mesh_node_ae_basic_node_static_unicast5_cc26x2r1_ccs_Release.hex
          • OA_3_6|Set Hex file ble5_simple_mesh_node_ae_basic_node_static_cc26x2r1_ccs_Release.hex
          • OA_3_7|Set Hex file ble5_simple_mesh_node_ae_relay_static_unicast7_cc26x2r1_ccs_Release.hex
          • OA_3_8|Set Hex file ble5_simple_mesh_node_ae_proxy_static_unicast8_cc26x2r1_ccs_Release.hex Success
      • Problem reproducibility:
        • 100%.
      • Problem description:
        • Mesh nodes with AE fail to send/receive messages after certain amount of messages are being transferred in the network.
        • The issue occurs both for LED messages, and large vendor messages.
      • Steps to reproduce the issue:
        • setup a network
        • start sending messages between nodes in the network
        • after a certain amount of time, nodes will completely fail to send/receive messages.
      • Attachments:
        • Large Vendor test + LED vendor test results tables
        • Network log

      Attachments

        Activity

          People

            syncuser TI User
            syncuser TI User
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: